Lets Encrypt SSL certifikát a nastavení https

Úvodní stránka Fórum podpory WordPressu Šablony, CSS (zobrazení webu) Lets Encrypt SSL certifikát a nastavení https

Zvolené téma obsahuje celkem 14 odpovědí. Do diskuze (5 účastníků) se naposledy zapojil uživatel  admin a poslední změna je stará 7 měsíců.

Aktuálně je na stránce zobrazeno 15 příspěvků - 1. až 15. (z celkem 15)
  • Autor
    Příspěvky
  • #34736

    Lubos237
    Participant

    Zdravím,

    web http://www.vysokorychlostni-zeleznice.cz mám na webhostingu SAVANA, používám WordPress 4.7.9 a šablonu Twenty Fourteen.

    Přes webhosting jsem si nainstaloval Lets Encrypt SSL certifikát. Mám 2 problémy:

    1/ webová prezentace https://www.vysokorychlostni-zeleznice.cz/ se mi ne vždy načítá korektně s šablonou (https snad nenačítá CSS), prý je na to nutné mít nainstalovaný plugin Really Simple SSL. Opravdu potřebuji další plugin? Na stejném webhostingu mám ještě https://www.bytrosice.cz/, tam jsem provedl stejnou instalaci Lets Encrypt SSL a zobrazuje se bez problémů

    2/ jak a kde nastavit, aby se prezentace načítala ve verzi
    https a ne v http? Ve WP v Nastavení jsem to nenašel.

    Děkuji za radu,

    Luboš

    #34737

    LuCaCZ
    Participant

    Tak pro začátek by bylo fajn aktualizovat WP na nejnovější verzi…

    Dál je to jednoduché. Nastavit URL Instalace WP a Úvodní stránka webu na https.
    Admin > Nastavení > Obecné.

    Pak možno postupovat podle tohoto návodu https://www.wplama.cz/jak-nastavit-wordpress-z-http-na-https/

    #34738

    Lubos237
    Participant

    Používám multisite, tam v Nastavení/ obbecné nikde nebyla Instalace WordPressu (URL) a Úvodní stránka webu (URL) možnost nastavit https://, tak jsem raději nainstaloval plugin Really Simple SSL. Instalace proběhla bez problémů, aktivoval jsem v síti webů a píše mi to:
    success SSL is enabled on your site.
    error The mixed content fixer is active, but was not detected on the frontpage.
    success An SSL certificate was detected on your site.
    success 301 redirect to https set: WordPress redirect

    … ale výsledek je stejný, prezentace ve verzi https://www.vysokorychlostni-zeleznice.cz je rozbitá, nenčítá se šablona. Tak nevím, co kde změnit. Pro jistotu jsem ani nenastavil “https” v Google Search Console/Webmaster Tools a Analytics.

    #34751

    Tomáš
    Participant

    Mi se web načítá téměř bez problémů, jediná chyba je u baneru odkazujícího na JÍZDENKY DO NĚMECKA/ ZÁPADNÍ EVROPY, který jako jediný načítá data přes http.

    #34752

    Lubos237
    Participant

    Jo, dnes už se zdá být vše v pořádku. :-) U banneru jsem ručně přepsal http na https. Díky za upozornění!

    Nevíte zda ten plugin Really Simple SSL automaticky přesměrovává i pixel (obrázek) na měření konverzí typu <img src="http://banners.webmasterplan.com/view.asp?ref=720087&site=2894&type=text&tnb=230" BORDER="0" WIDTH="1" HEIGHT="1" /> z http na https ? Přestaly se mi od včerejška počítat konverze. :-(

    #34756

    admin
    Keymaster
    Web

    Projděte si prosím podobné téma, kde jsme už dříve řešili, že odkazovaný návod (s použitím pluginu) je nedostatečný a vede k různým problémům. Správný postup spočívá v migraci celé databáze a nahrazení https://www.separatista.net -> https://www.separatista.net. Použitím pluginu přechod na HTTPS pouze oddálíte a stejně to budete muset jednou udělat ručně, abyste ho tam nemuseli nechávat věčně :-)

    #34758

    mirekk
    Participant
    Web

    Ano, je to tak. Já osobně jsem se toho taky bál, ale pokud si zazálohujete databáze, bát se nemusíte.
    Pokud už máte certifikát, to ostatní je záležitost jedné jediné minuty. Fakt, nekecám, je to tak jednoduché. Postup jsem popsal tady >>

    Edit: je potřeba plugin pro přepsání všech adres v databázích, ale ten po jeho použití smažete. Píšu to proto, abyste si nemyslel, že vám taky nabízím řešení s pluginem :-)

    #34765

    Lubos237
    Participant

    Přečetl jsem si celé téma jak radil @admin. Deaktivoval jsem tedy používaný plugin Really Simple SSL, nainstaloval plugin Better Search Replace
    , plugin jsem nechal přepsat adresy http na https. Po provední mi to napsalo “DRY RUN: 72 tables were searched, 11807 cells were found that need to be updated, and 0 changes were made”. A nyní se prezentace zobrazuje zase divně bez šablony. S tím pluginem Really Simple SSL to alespoň po nějaké době jelo ok.

    #34767

    Lubos237
    Participant

    Zkusil jsem zpět aktivovat plugin Really Simple SSL v síti webu a teď dokonce už ani administrace WP pod https://www.vysokorychlostni-zeleznice.cz/wp-admin nemá žádný vzhled backendu WP. :-( Musím se přihlašovat pod starým http://www.vysokorychlostni-zeleznice.cz/wp-admin

    #34770

    mirekk
    Participant
    Web

    1. Při instalaci certifikátu – zvolil jste možnost jak s www tak i bez www?
    2. Když se podívám na váš web s https vidím tam, že kromě položky Přejít k obsahu webu všechny ostatní odkazy máte bez https:// Podle mě to znamená, že v databázích máte i formu bez http a měl byste přepsat i tyto.
    3. Nemáte někde v šabloně udělané vlastní úpravy, kde byste měl natvrdo vložené adresy s www ?
    4. Používáte správně plugin Better Search Replace? Mám tím na mysli jestli máte zrušené zaškrtnutí u položky Run as dry run aby se změny opravdu provedly

    Certifikáty jsem instaloval už na několika webech a vždy naprosto bez problému na první pokus.
    Ještě dodám – používáte cachovací plugin, takže po přepisu adres musíte vyčistit cache jak pluginu, tak potom i svého prohlížeče

    #34771

    Lubos237
    Participant

    1. ano, certifikát Let’s Encrypt je na vysokorychlostni-zeleznice.cz i na http://www.vysokorychlostni-zeleznice.cz
    2. taky když se podívím do databáze do souborů wp_posts, wp_options tak vidím verzi jen http
    3. v šabloně mám jen úpravu css týkající se zobrazování:

    #program form, #program table, #program caption, #program tbody, #program tfoot, #program thead, #program tr, #program th, #program td {
    	border: 0;
    	margin: 0;
    	outline: 0;
    	padding: 0;
    	font-size: 100%;
    }
    
    #program td {
    	padding: 0 0 1px;
    }
    
    .widget-area .widget input, .widget-area .widget textarea {
    	font-size: 100%;
    }
    
    input {
    	height: auto !important;
    }

    4. ano, měl jsem zaškrtnuto Run as dry run. Zrušil jsem zaškrtnutí a zkouším přepsat http na https znovu. Hlásí to chybu: An error occurred processing your request. Try decreasing the “Max Page Size”, or contact support. Pro Max Page Size jsem nastavil maximum – Current Setting: 50000. Pořád hlásilo chybu, pak jsem zkoušel rozdělit na 2 várky i na 3 várky a nic neprošlo. Vždy se to sekne zhruba u stejného wp souboru.
    5. nemůže být problém v tom, že mám multisite?

    Chtěl bych se raději vrátit ke své staré databázi před těmito úpravami. Mám ji zálohovanou. Jak to v PHPMyAdmin u Savany provést. Zkjoušel jsem ji jen naimportovat pod stejným názvem a hlásilo to chybu, že nějaký soubor již existuje. Mám tedy současnou databázi smazat a naiorotvat tu ze zálohy?

    Děkuji,

    Luboš

    #34772

    mirekk
    Participant
    Web

    To je divný. Zkuste tedy napsat místnímu adminovi mail, určitě se dohodnete a podívá se vám na to.

    Databázi nemažte, jen všechny tabulky a pak naimportujte ty ze zálohy.

    #34773

    Lubos237
    Participant

    Díky za snahu a rady! Napsal jsem na pavelevap@separatista.net.

    #34775

    Lubos237
    Participant

    @admin: je to prosím váš mail? pavelevap@separatista.net Psal jsem vám s žádostí o placenou pomoc.

    #34776

    admin
    Keymaster
    Web

    Ano, díky, dostanu se k tomu odpoledne/večer.

Aktuálně je na stránce zobrazeno 15 příspěvků - 1. až 15. (z celkem 15)

Pokud chcete odpovědět na toto téma, musíte se nejdříve přihlásit.

WordPress – novinky, návody a zajímavosti