Problém s knihovnou medíí

Zvolené téma obsahuje celkem 2 odpovědi. Do diskuze (2 účastníci) se naposledy zapojil uživatel  Azifaral a poslední změna je stará 4 roky, 6 měsíců.

Aktuálně jsou na stránce zobrazeny 3 příspěvky - 1. až 3. (z celkem 3)
  • Autor
    Příspěvky
  • #22031

    Azifaral
    Participant
    Web

    Zdravím,

    mám problém s nahráváním obrázků. Jedná se o web, který jsem začal připravovat loni v květnu a potom šel na chvíli k ledu a teď jsem se k němu vrátil. A není problém v tom, že bych je nebyl schopen nahrávat, ale v tom, že mi je ukládá jenom do folderu 2014/05, což je folder, který vzniknul při založení. A stejné image mi jenom zobrazuje, respektive zobrazuje image z 05-06/2014.

    A aby toho nebylo málo, tak takto to funguje když jsem v Knihovně médií. Když jsem zkusil vkládat post a udělal jsem tam upload těch image, tak mi je dal do správného folderu, tzn. do 2015/02, ale když jsem se potom podíval do Knihovny médií, tak mi je nezobrazil.

    Zkontroloval jsem nastavení v dtb, ale obecně nevím co bych tam nastavoval, protože ten upload proběhne, ale do špatného folderu. Zkoušel jsem něco vygooglit a nějak jsem s tím nehnul.

    Potkal jste se někdo už s tím?
    Díky
    Pavel

    #22034

    admin
    Keymaster
    Web

    Nevím, jestli jsem to celé správně pochopil…

    Obecně se obrázky nahrávají do adresáře s datem podle toho, kdy byl publikován konkrétní příspěvek. Takže když jste publikoval příspěvek (či stránku) v květnu 2014 a nyní k němu nahrajete nějaké další mediální soubory, tak budou opět uloženy do staršího adresáře 2014/05, aby zůstaly pohromadě…

    A když vytvoříte nový příspěvek (únor 2015), tak sice obrázky v pořádku nahrajete, ale nezobrazí se v Knihovně médií ani na webu? Zkoušel jste deaktivovat všechny pluginy a nasadit výchozí šablonu Twenty Fifteen?

    #22040

    Azifaral
    Participant
    Web

    Já to nakonec vzdal a vzhledem k tomu, že na tom serveru těch dat bylo málo, tak jsem to udělal z čisté vody. Nicméně ta chyba byla trošku jinak.

    1. Nahrál jsem image v Knihovně médií a on místo toho aby se uložil do folderu /2015/02 tak se uložil do 2014/05. A po refreshnutí Knihovny, nebo když jsem dal zakládat post, tak jsem prostě ten image v té Knihovně neviděl a tím pádem jsem jej nemohl vložit do postu. I když na serveru prokazatelně byl, to jsme se koukal, přes FTP.

    Po vypínání pluginů se to sice začalo tvářit lépe, ale postupně jsme došel k tomu, že problém byl asi ve WPML a to díky tomu, že jsem “já optimista + viz naše diskuse o tom, že by mohla pomoct ve výkonu, ale zcela jistě bude mít chybu jinde” tam hodil tu jejich betu. Kolegyně mi tady říkala ať to nedělám a vzpomenu si na předchozí betu, která měla zase pro změnu problém s TAGY, kdy v druhém jazyku po překladu vyráběla nekontrolovatelné množství odkazů :D. Ale já jsem vždycky takový dobrodruh ;) :D. A co se týká WPML, tak tam to je skoro vždycky natuho a nepomůže ani to, že bych tam dal starší verzi, oni to prostě vždycky někde zprasí v databázi. Ale i přes ty problémy co s ním bývají je to boží plugin.

    Takže snad už to teď po reinstalaci bude ok.

Aktuálně jsou na stránce zobrazeny 3 příspěvky - 1. až 3. (z celkem 3)

Pokud chcete odpovědět na toto téma, musíte se nejdříve přihlásit.