Krizový plán přeinstalování WP

Úvodní stránka Fórum podpory WordPressu Problémy s WordPressem Krizový plán přeinstalování WP

Zvolené téma obsahuje celkem 1 odpověď. Do diskuze (2 účastníci) se naposledy zapojil uživatel  admin a poslední změna je stará 2 roky, 6 měsíců.

Aktuálně jsou na stránce zobrazeny 2 příspěvky - 1. až 2. (z celkem 2)
  • Autor
    Příspěvky
  • #32750

    d139132
    Participant

    Zdravím,
    měl bych dotaz. Řeším pro naši firmu krizový plán pro případ, že bude náš web napaden a vyřazen z provozu. Mám k dispozici týdenní zálohy WP + db.
    Co se stane v případě, že nainstaluji novější verzi a do databáze importuji data ze starší verze, bude to fungovat? V tuto chvíli používáme verzi 4.2.15. Nebo musím použít stejnou verzi WP a pak případně aktualizovat na vyšší verzi.
    S tím souvisí můj dotaz: dělají si šablony v DB nějaké vlastní struktury, které by při nové instalaci WP a importu DB mohli dělat nějakou neplechu? A taktéž se chci zeptat na pluginy, zda při nové instalaci nebudu mít také nějaký problém.
    Případně pokud je někde nějaký postup nejlepšího řešení?
    Ještě poslední. Je nutné aktualizovat WP? Z praxe vím, že mnoho aktualizací funguje tak, že jednu věc zazáplatují a další díru vytvoří, nebo se dosáhne různých nekompatibilit, jak je to u WP? Stačí automatické aktualizace, které si provádí WP sám?
    Děkuji.

    #32765

    admin
    Keymaster
    Web

    – Pokud se na webu nic nemění, tak asi týdenní záloha stačí, ale třeba tady na fóru se toho mění poměrně dost, takže tam je potřeba záloha častější. Kdyby došlo k poškození webu, tak bych nechtěl přijít o týdenní diskuze :-)

    – Pokud ke starší databázi nahrajete nejnovější WordPress, tak dojde vlastně k ruční aktualizaci. Při prvním načtení WordPressu pak dojde k aktualizaci databáze a budete mít vše nejnovější.

    – Doporučil bych aktualizovat na nejnovější verzi WordPressu.

    – Se šablonami je obecně trochu problém, většina se chová standardně a z hlediska databáze tam není žádný problém s aktualizací (používají nastavení v rámci theme_mods_), ale různé placené šablony mohou provádět různé podivné věci, klidně si vytvářet i vlastní databázové tabulky, těžko říci. Pokud je ale šablona aktuální (a autor ji stále průběžně aktualizuje, tak by to neměl být problém). Riziko problémů je myslím dost nízké (několikaprocentní), ale můžete to třeba někde nanečisto vyzkoušet.

    – S pluginy je to ještě horší :-) Musíte sledovat kompatibilitu, aktualizace, předem se na to asi moc nepřipravíte. Některé pluginy mohou přestat s novou verzí WordPressu fungovat (a nemusí to být kvůli databázi, ale jiným problémům, např. použité funkce, změna hooků, atd).

    – Osobně doporučuji aktualizovat alespoň jednou za dva roky. Místní web aktualizuji většinou jednou za půl roku, většinou vždy čekám na opravnou verzi :-) Pokud na současné verzi 4.2.15 není žádný problém, tak nemusíte spěchat, bezpečnostní aktualizace jsou automaticky aplikovány. Ale asi by to časem aktualizovat chtělo, sice s tím možná budou nějaké drobné problémy (hodně záleží na pluginech a šabloně), ale pak to zase můžete nechat dva roky být :-)

Aktuálně jsou na stránce zobrazeny 2 příspěvky - 1. až 2. (z celkem 2)

Pokud chcete odpovědět na toto téma, musíte se nejdříve přihlásit.