WordPress se sám zaktualizoval na v. 4.7

Úvodní stránka Fórum podpory WordPressu Problémy s WordPressem WordPress se sám zaktualizoval na v. 4.7

Zvolené téma obsahuje celkem 7 odpovědí. Do diskuze (4 účastníci) se naposledy zapojil uživatel  jr a poslední změna je stará 3 měsíce, 2 týdny.

Aktuálně je na stránce zobrazeno 8 příspěvků - 1. až 8. (z celkem 8)
  • Autor
    Příspěvky
  • #30049

    jr
    Participant

    Dobrý den,
    tento dotaz jistě zní zcela kuriózně a ultra-začátečnicky, ale vrtá mi to hlavou, tak píšu. Dnes v noci se mi sám od sebe zaktualizoval WP na verzi 4.7. A nemohu příjít na to, proč (resp. zda to není průvodní signál něčeho špatného)…
    Nesetkali jste se někdo s něčím podobným? Pátral jsem všude možně – v JetPacku aut. aktualizace zapnuté nemám a na mých dalších webech nastavených podobně se to nestalo… Zkoušel jsem proskenovat přes Wordfence, nic nehlásí, zálohy v VaultPressu jsou v pořádku, záhada, které mě znervózňuje…
    Díky za případnou radu!
    JR

    #30050

    Azifaral
    Participant
    Web

    Dobrý den,

    automatická aktualizace WordPressu je od verze 3.7 normální záležitost v případě „desetinkových“ aktualizací, tzn. že automatický update pokud jej nezakážete (viz níže) bude probíhat u verzí 4.6.1 na 4.6.2, případně jak to bylo teď z verze 4.6 na 4.7.

    Co se týká zákazu a povolení tak se to nastavuje v souboru wp-config.php a to takto:
    Zákaz: define('WP_AUTO_UPDATE_CORE', false);
    Povolení: define('WP_AUTO_UPDATE_CORE', true);

    #30051

    admin
    Keymaster
    Web

    @jr: Aktualizace na WordPress 4.7 by určitě neměla proběhnout sama od sebe. To bychom tu měli dnes už 100 dotazů :-) Patrně to máte povolené v souboru wp-config.php nebo nějak nastavené v rámci nějakého pluginu, např. Jetpack to myslím umí, třeba to tam máte někde zaškrtnuté.

    #30052

    jr
    Participant

    Pánové, děkuji Vám oběma moc… Ano, ve wp-config.php to mám „true“, ale netušil jsem, že se to týká i aktualizací velkých verzí, je možné, že jsem to někde odklikl, ještě popátrám…
    Tedy, abych to pochopil, „true“ ve wp-config.php znamená, že se aktualizují všechny verze, včetně přechodu na „velkou“, jako dnes 4.7? (Měl jsem dojem, že se to týká jen těch desetinkových, ty samozřejmě běží…)
    Díky ještě jednou!
    JR

    #30053

    Azifaral
    Participant
    Web

    Oops omlouvám se, samozřejmě jsem kecal, jenom ty desetinkové. Takže na tu velkou by se vám to updatovat nemělo.

    #30054

    Kurt
    Participant
    Web

    Ano, pokud je v wp-config.php uvedena hodnota define( 'WP_AUTO_UPDATE_CORE', true ); pak se aktualizuje WP všemi verzemi, tedy i z 4.6 na 4.7.
    Popsáno je to zde: https://codex.wordpress.org/Configuring_Automatic_Background_Updates

    #30056

    admin
    Keymaster
    Web

    Díky všem :-)

    @jr: Buď můžete celý ten řádek z wp-config.php smazat a vrátíte se k defaultnímu chování, tedy automatické aktualizace jen na malé verze. Nebo můžete změnit hodnotu pro WP_AUTO_UPDATE_CORE z true na minor, což je vlastně to samé. Nebo to nechat všechno povolené tak jako dosud :-) Ale žádný problém tam není, vše funguje tak, jak by správně mělo…

    #30057

    jr
    Participant

    Díky moc!! To jsem rád, že tímto se to vysvětluje, sice nevím, jak se mi to podařilo pustit, ale mě primárně šlo o to, aby to nebyl přiznak nějakého průšvihu… Tedy díky ještě jednou!
    JR

Aktuálně je na stránce zobrazeno 8 příspěvků - 1. až 8. (z celkem 8)

Pokud chcete odpovědět na toto téma, musíte se nejdříve přihlásit.