Widget na RSS nekompatibilní s PHPBB

Úvodní stránka Fórum podpory WordPressu Problémy s WordPressem Widget na RSS nekompatibilní s PHPBB

Zvolené téma obsahuje celkem 7 odpovědí. Do diskuze (2 účastníci) se naposledy zapojil uživatel  polokolo a poslední změna je stará 1 rok, 10 měsíců.

Aktuálně je na stránce zobrazeno 8 příspěvků - 1. až 8. (z celkem 8)
  • Autor
    Příspěvky
  • #34153

    polokolo
    Participant

    Provozujeme web o svádění a osobním rozvoji. Na subdoméně provozujeme PHPBB fórum baličské komunity.

    V menu webu bychom rádi měli widget nejnovějších příspěvků z fóra: https://forum.streetgame.cz/feed

    Widget ale nefunguje. Před RSS feedem se mi zobrazuje mnohokrát varování: Warning: A non-numeric value encountered in /data/web/virtuals/25378/virtual/www/domains/streetgame.cz/wp-includes/SimplePie/Parse/Date.php on line 694

    To se děje, i když nepoužiju zabudovaný widget, a stáhnu na zobrazování RSS nějaký plugin. Stejně tak, když RSS nenačítám z našeho fóra, ale z jiného PHPBB 3.2 fóra.

    #34183

    admin
    Keymaster
    Web

    Ano, je to problém na straně WordPressu, který používá pro parsování RSS knihovnu SimplePie, ale neobsahuje zatím nejnovější opravenou verzi.

    Buď si to můžete dočasně opravit (viz výše uvedený odkaz na problém) nebo musíte změnit u hostingu verzi PHP na nějakou nižší než 7.1.

    #34186

    polokolo
    Participant

    Díky, kde přesně to prosím mám opravit?

    (Mimochodem gratuluji separatista.net k přechodu na https!)

    #34187

    admin
    Keymaster
    Web

    wp-includes/SimplePie/Parse/Date.php, řádek 694

    Oprava: https://github.com/simplepie/simplepie/commit/1111dab1baced14aaf05509c41ee416c3fc6a961

    Možná by ale stačilo přepnout PHP z verze 7.1 na 7.0 a mělo by to fungovat bez problémů…

    #34193

    polokolo
    Participant

    Řádek opraven, nyní to hlásí Warning: A non-numeric value encountered on line 1387. Co ještě upravit?

    Wordpress komunita o tom tedy ví a v budoucnu to opraví v další verzi sama?

    #34411

    polokolo
    Participant

    Nebo kam jim mám dát vědět, že to hlásí ještě další chybu? Dostanu za to odměnu?

    #34506

    polokolo
    Participant

    Aktualizoval jsem wordpress na dnešní novou verzi a nepomohlo to, problém stále trvá.

    #34653

    polokolo
    Participant

    A znova, ani další verze wordpressu chybu neopravuje

Aktuálně je na stránce zobrazeno 8 příspěvků - 1. až 8. (z celkem 8)

Pokud chcete odpovědět na toto téma, musíte se nejdříve přihlásit.