SPAM – Pingbacky a trackbacky

Úvodní stránka Fórum podpory WordPressu Problémy s WordPressem SPAM – Pingbacky a trackbacky

Štítky: , ,

Zvolené téma obsahuje celkem 5 odpovědí. Do diskuze (3 účastníci) se naposledy zapojil uživatel  Russl a poslední změna je stará 3 roky, 9 měsíců.

Aktuálně je na stránce zobrazeno 6 příspěvků - 1. až 6. (z celkem 6)
  • Autor
    Příspěvky
  • #21215

    aldik7
    Participant

    Zdravím, chtěl bych se zeptat jestli existuje třeba nějaký skript nebo jiný způsob, jak hromadně ve všech příspěvcích a stránkách zakázat pingbacky a trackbacky? Poslední dobou si náš web nějak oblíbil nějaký spamující robot (nejspíš z Ruska, ale to není podstatné) a i když jsem v nastavení zakázal pingbacky a trackbacky tak to funguje bohužel jen u nových příspěvků a měnit to ručně u všech příspěvků by bylo fakt na dlouho, i když asi mi nic jiného nezbude (hromadně to jde vždy jen na jedné stránce, ale pořád je to málo.. příspěvků máme aktuálně už na 32 stránek!).

    #21219

    sjiamnocna
    Participant
    Web

    Zdravím, nejednodušší asi bude zakázat to manuálně přes hromadné úpravy. V menu nastavení zobrazení, si můžete zadat počet příspěvku na stránce. Zvolte maximální možný a pak pokračujte normálně jako při hromadné úpravě.

    Druhou možností je změna v databáze, a to v tabulce wp_posts sloupce comment_status a ping-status. Poté jednoduchým zápisem můžete obě tyto hodnoty změnit u všech příspěvků, v okně SQL příkazů (phpMyAdmin) anebo v SQL příkazu (v Admineru):

    UPDATE wp4_posts
    SET comment_status=0, ping_status=0

    V nejhorším případě :) můžete použít plugin, např.
    https://wordpress.org/plugins/disable-comments/

    #21221

    aldik7
    Participant

    Z toho kódu asi bych měl vynechal to ‘comment_status=0’ nebo se to nevztahuje na komentáře? Já chci zakázat jen trackbacky a pingbacky zakázat, komentáře má na starosti Disqus a tam spam nepronikává naštěstí :)

    Jinak phpMyAdmin mi hlásí chybu:

    #1064 – You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near ‘UPDATE wp4_posts SET ping_status=0 LIMIT 0, 100’ at line 2

    #21239

    aldik7
    Participant

    Beru zpět, už se mi to podařilo, chyba byla objevena- pingbacky u všech příspěvků vypnuty. ;)

    #21246

    sjiamnocna
    Participant
    Web

    Jinak phpMyAdmin mi hlásí chybu:

    #1064 – You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near ‚UPDATE wp4_posts SET ping_status=0 LIMIT 0, 100′ at line 2

    Ono je to potřeba převést do poměrů vaší vlastní databáze a hlavně vlastní předpony, tzn wp4_ může být klidně mujkrasnywordpress_. S disqusem moc nespolupracuju, mám rád vestavěné funkce a třeba nějaký Akismet ap.

    #24419

    Russl
    Participant

    Tak mě to trápí také, ale v databázi se bojím hrabat :( Existuje ještě nějaká jiná varianta ???? Díky

Aktuálně je na stránce zobrazeno 6 příspěvků - 1. až 6. (z celkem 6)

Pokud chcete odpovědět na toto téma, musíte se nejdříve přihlásit.