Šablony…

Zvolené téma obsahuje celkem 8 odpovědí. Do diskuze (3 účastníci) se naposledy zapojil uživatel  admin a poslední změna je stará 5 let, 9 měsíců.

Aktuálně je na stránce zobrazeno 9 příspěvků - 1. až 9. (z celkem 9)
  • Autor
    Příspěvky
  • #6581

    bjora
    Participant

    Ahoj, kdo mi prosím vysvětlí, co je špatně… Stáhla a postupně jsem aktivovala např. šablonu Spun 2.0.2 nebo Snaps 1.0.2 a ani jedna se nezobrazí a píše mi to info o errorech. Jsu z toho otrávená… Jsem chtěla nějakou efektní šablonu. To se mám spokojit s těmi počeštěnými Tventy Eleven atp.? Díky.

    #17823

    admin
    Keymaster
    Web

    Jaké konkrétní chyby se po jejich aktivaci zobrazují?

    #17824

    bjora
    Participant

    U SNAPS je to:

    Fatal error: Call to undefined function get_custom_header() in /www/doc/www.graftone.cz/www/wp-content/themes/snaps/header.php on line 30

    U SPUN je to:

    Fatal error: Call to undefined function is_multi_author() in /www/doc/www.graftone.cz/www/wp-content/themes/spun/inc/extras.php on line 26

    Podotýkám,že nějaké zkušenosti s html mám, ale s tímhle si vůbec nevím rady… :o(

    Děkuji!

    #17825

    admin
    Keymaster
    Web

    Jakou máte verzi WordPressu?

    #17826

    bjora
    Participant

    2.8.4.

    #17827

    bjora
    Participant

    Když zaktualizuji na 3.8.1 , bude to ok?

    #17828

    mirekk
    Participant
    Web

    Šablonu Spun jsem zkusil nainstalovat a aktivovat, bez problémů na WP 3.8.1.

    Určitě není důvod používat zastaralou verzi WP. Nebo máte nějaký zvláštní důvod neaktualizovat na 3.8.1?

    #17829

    bjora
    Participant

    Určitě ;o) Jestli to bude tím, tak děkuji a jestli ne, tak taky děkuji ale budu otravovat dál. Hezký den!

    #17830

    admin
    Keymaster
    Web

    Určitě to bude způsobeno velmi starou verzí WordPressu. Šablony Spun a Snaps jsou poměrně nedávno aktualizované a hodně také napovídají chybové hlášky. Funkce get_custom_header() byla přidána ve WordPressu 3.4 (možnost nastavení vlastního záhlaví) a funkce is_multi_author je zase novinka WordPressu 3.2. Takže pokud máte zastaralý WordPress, tak tam funkce nejsou definovány a dojde k chybě. A nové šablony nemusí podporovat zastaralé funkce (i když by mohly a některé to i dělají).

Aktuálně je na stránce zobrazeno 9 příspěvků - 1. až 9. (z celkem 9)

Pokud chcete odpovědět na toto téma, musíte se nejdříve přihlásit.