Problém s rubrikou

Štítky: ,

Zvolené téma obsahuje celkem 7 odpovědí. Do diskuze (3 účastníci) se naposledy zapojil uživatel  jakub.sachr@tadyated.org a poslední změna je stará 3 roky, 1 měsíc.

Aktuálně je na stránce zobrazeno 8 příspěvků - 1. až 8. (z celkem 8)
  • Autor
    Příspěvky
  • #26717

    honza94
    Participant

    Dobrý den mam takový problém nezobrazují se mi příspěvky v rubrice na stránkách.Pouze v jedné v ostatních se zobrazují normálně. Přitom jsou do ní zařazeny a v administraci pokud kliknu na rubriky. Tak jak je vpravo číslo počet článků v rubrice. Tam mam správně počet článků v ní, ale když na to číslo kliknu tak se nezobrazí ani jeden. Jinak články jsou publikované a na webu viditelné pokud se na ně dostanu jinak.

    #26718

    honza94
    Participant

    PS: ted to jde zase normálně a vše je viditelné. Nechápu to. Přitom předtím když jsem zadal třeba druhou stránku s články v kategorii tak to psalo 404

    #26723

    admin
    Keymaster
    Web

    A nefungovalo tedy zobrazení žádné rubriky? Nebo jen některých? Nebo jen druhá stránka archivu, např. category/nezarazene/page/2?

    Občas se to stává při použití nějakého pluginu či nekorektní úpravy a je potřeba aktualizovat strukturu trvalých odkazů v menu Nastavení – Trvalé odkazy.

    #26730

    honza94
    Participant

    Nefungovalo zobrazí pouze u jedné. Všechny ostatní v pořádku
    V administraci byl v seznamu rubrik u ní uveden správný počet článků, které obsahuje ale když jsem klikl na tu rubriku nebyl v ní vidět ani jeden.

    Na stránkách při kliknutí na rubriku se zobrazila informace, že doposud v rubrice není žádný příspěvek. Přitom jich tam je přes 400.
    Vyzkoušel jsem tu druhou stránku rubriky a ta neexistovala 404 chyba.

    Při přímém odkazu na článek z problémové rubriky se normálně zobrazoval na webu.

    #26749

    admin
    Keymaster
    Web

    Díky, takže i když se v rubrice neobjevoval žádný příspěvek, tak tam bylo stejně vidět stránkování (a tedy i odkaz na další stránku), které ale nefungovalo a byla tam chyba 404? A pak to z ničeho nic začalo fungovat? Tak to je trochu záhadné chování, těžko říci, čím by to mohlo být způsobeno. Nemohl jste třeba změnit nějaké nastavení nebo deaktivovat nějaký plugin? Na příčinu už ale asi nepřijdeme, možná se s tímto problémem časem setká někdo další…

    #26769

    honza94
    Participant

    Stránkování vidět nebylo. To mě jen napadlo vyzkoušet, že jsem si pamatoval url adresu stránky dvě.
    Následně to po nějaké době se začalo zase normálně objevovat.

    #26775

    admin
    Keymaster
    Web

    Díky, bohužel mě nenapadá, čím by to mohlo být způsobeno. Snad nějaký konflikt s některým pluginem, těžko říci… Uvidíte, zda se to třeba ještě někdy objeví nebo to zaznamená nějaký další uživatel… Ale pokud už to bez problémů funguje, tak to patrně zůstane už jen jako nevysvětlená záhada :-)

    #27054

    Mám asi podobný problém. Nevím, jestli jsem rozhasil menu nebo mám špatně nastavený blog. Ale nejspíš se tak stalo z ničeho nic, jelikož před každou změnou si zobrazuji náhled…
    Podle mne po nějaké aktualizaci mi přestalo fungovat zobrazování příspěvků na stránkách. Ve widgetu, který mi zobrazuje archiv a nejnovější příspěvky, se mi příspěvek zobrazí po prokliknutí, na samotné stránce za použití blogu ale ne. A to je stejné na všech stránkách.
    Zkoušel jsem deaktivovat pluginy, jak tu někdo psal, a nic…
    Možná to je nějaká školácká chyba, ale nepřišel jsem na to.

Aktuálně je na stránce zobrazeno 8 příspěvků - 1. až 8. (z celkem 8)

Pokud chcete odpovědět na toto téma, musíte se nejdříve přihlásit.