Převod webu na jinou doménu – web přestal fungovat – pouze bílá obrazovka

Úvodní stránka Fórum podpory WordPressu Problémy s WordPressem Převod webu na jinou doménu – web přestal fungovat – pouze bílá obrazovka

Štítky: 

Zvolené téma neobsahuje zatím 1žádnou odpověď. Do diskuze (4 účastníci) se naposledy zapojil uživatel  Komplexni-Luke a poslední změna je stará 2 roky, 8 měsíců.

Aktuálně je na stránce zobrazeno 11 příspěvků - 1. až 11. (z celkem 11)
  • Autor
    Příspěvky
  • #31988

    Komplexni-Luke
    Participant

    Zdravím,

    převedl jsem web z domény test2.boombuzz.cz na doménu rusini.cz a web přestal fungovat na novém umístění . Přes plugin Duplicator – pro version ( celý web uloží i s databází do jedné zip složky a vytvoří soubor installer.php . Pak stačí tuto složku nahrát na nové umístění i se souborem a spustit domena.cz/installer.php a spustí se instalační skript.).

    Memory limit u hostingu je v pořádku ( na test2.boombuzz.cz web běží s memory limitem 128mb , je u FORPSI. Na rusini.cz má web k dispozici 256mb u Wedosu). Šablonu jsem zkoušel smazat a spustit web bez toho. Pak šablonu znovu nahrát. Změny se šablonou na to nemají také žádný vliv.

    Nemohu se dostat ani do administrace, přes link rusini.cz/wp-admin .

    Nezobrazují se ani chyby, když jsem přidal do wp-config tohle: define(‘WP_DEBUG’, true);

    Web jsem zkoušel i celý smazat a nainstalovat přes installer.php znovu.

    Soubory webu jsou všechny na umístění. Databáze je také nahraná celá. Memory limit na webhostingu je také dostatečný. Šablonou to také není. Web na testovací doméně funguje v pořádku i s nižším memory limitem, při převodu na novou doménu přestane fungovat.

    Se zákaznickou podporou Wedosu jsem komunikoval a z jejich strany je tam snad vše v pořádku.

    Prosím o radu.

    Čím to může být? Něco někde není správně nastaveno? V čem je chyba?

    Díky moc. Opravdu to hodně spěchá.

    Ať se Vám daří tady s Vašimi projekty :))

    Luke

    #31992

    admin
    Keymaster
    Web

    To je těžké, bílá obrazovka je nějaká PHP chyba (Fatal error), kterou budete muset nejdříve odhalit. Zapněte si u Wedosu logování chyb (na 24 hodin je to zdarma) a uvidíte, zda se tam něco objeví… A pokud jde o Wedos, tak pozor i na soubor .htaccess, který by měl obsahovat jejich pravidla…

    #31994

    VitaZ
    Participant

    Mám aktuálně u Wedosu stejný problém při nové instalaci wordpressu. Zřízen nový hosting a při pokusu o čistou instalaci nijak neupravovaného wordpressu skončí načtení stránky install.php bílou obrazovkou. WP DEBUG nezobrazí nic, chrome ukazuje chybu 500, ale v .htaccess zřejmě chyba nebude, protože statická stránka index.html se normálně zobrazí. Pokus o instalaci nějaké starší verze wordpressu skončí stejně. Podporu Wedosu jsem zatím nekontaktoval, zkoušel najít chybu někde u sebe, ale teď vidím, že v tom nejsem sám. Hosting nabataku.cz

    #31996

    admin
    Keymaster
    Web

    Díky, zkusil bych asi nejdříve podporu, možná mají nějaký výpadek nebo problém s PHP. Pokud se nezadaří, tak mi pošlete přístupy na FTP, zkusím se na to podívat…

    #31997

    Komplexni-Luke
    Participant

    Díky za odpověď.

    .htaccess by měl být v pořádku, v administraci jsem pro jistotu obnovil .htaccess.

    S tím errorlogem je to úplně záhada. Měl jsem errorlog spuštěný od včerejška, teď jsem kontroloval složku z logy přes ftp ( dle tohoto návodu https://hosting.wedos.com/cs/webhosting/logy.html ) . A ve složce je akorát přes 20 prázdných textových souborů.

    #31999

    VitaZ
    Participant

    Prosil bych o radu, kde u Wedosu aktivovat to logování chyb, v menu administrace hostingu to nikde nevidím. Díky.

    #32000

    Komplexni-Luke
    Participant
    #32001

    admin
    Keymaster
    Web

    Zkuste do wp-config.php vložit:

    define( 'WP_DEBUG', true );
    define( 'WP_DEBUG_LOG', true );

    Následně zobrazit chybu (bílou stránku) a poté se podívat do adresáře wp-content, zda tam nevznikl soubor debug.log se zaznamenanými chybami.

    #32003

    Komplexni-Luke
    Participant

    Díky. Zkusil jsem. Ale soubor se tam žádný nevytvořil.

    Upřímně je to pro mě docela záhada. Duplicator používám opakovaně. Web na test2 funguje se vším všudy a pak se tam vytvoří někde chyba a přestane fungovat.

    #32016

    Kovanda
    Participant

    Dobrý den,

    tak jsem zkusil provést instalaci WP z Duplikátoru u Wedosu na svém test webu a vše proběhlo bez problému.

    Verze pluginu Duplicator 1.2.2
    Operační systrém Linux
    Webový server Apache
    APC povoleno No
    WordPress
    Verze 4.7.3
    Jazyk cs-CZ
    Sada znaků UTF-8
    Limit paměti 128M (Max. 128M)
    PHP
    Verze 5.6.23
    Limit paměti 128M
    Využitá paměť 20,25 MB
    Max. čas provádění 90

    #32033

    Komplexni-Luke
    Participant

    Díky všem za pomoc a rady.

    Díky Kovanda za vyzkoušení jestli to funguje všechno :). Když jsem web překopíroval přes duplicator, tak se na webu nezobrazovaly žádné chyby, i přesto že web nefungoval (nezobrazovaly se chyby ani při použití postupů k odhalení).

    Překopíroval jsem web přes plugin WP Clone . A již se zobrazila chyba, kterou mi Admin vysvětlil o co se jedná. Verze šablony nepodporovala verzi PHP7 , která byla na webhostingu Wedosu. V administraci jsem změnil nastavení na verzi PHP 5.6. . Vše již funguje v pořádku.

Aktuálně je na stránce zobrazeno 11 příspěvků - 1. až 11. (z celkem 11)

Pokud chcete odpovědět na toto téma, musíte se nejdříve přihlásit.