Přechod PHP na vyšší verzi ve WordPressu

Úvodní stránka Fórum podpory WordPressu Problémy s WordPressem Přechod PHP na vyšší verzi ve WordPressu

Štítky: 

Zvolené téma obsahuje celkem 6 odpovědí. Do diskuze (3 účastníci) se naposledy zapojil uživatel  zjesu a poslední změna je stará 2 roky, 2 měsíce.

Aktuálně je na stránce zobrazeno 7 příspěvků - 1. až 7. (z celkem 7)
  • Autor
    Příspěvky
  • #24398

    SonyFalko
    Participant

    Zdravím.

    Máme web dělaný ve WordPressu a potřebujeme přejít z verze PHP 5.3.2.9 na verzi 5.5, nebo 5.6.

    Chtěl by jsem se zeptat jestli to je možné? Můžou nastat nějaká rizika? Jak se to dělá?

    Děkuji za odpovědi.

    #24402

    admin
    Keymaster
    Web

    Nemělo by se stát téměř nic, už několikrát jsem přecházel z PHP 5.2.x na 5.6.x a žádný problém jsem zatím nezaznamenal. Některé hostingy umožňují uživatelům, že si mohou verze v administraci hostingu sami přepínat (a zkoušet). Teoreticky by mohly nastat nějaké problémy s šablonou či pluginy, ale spíše výjimečně.

    Stačí napsat na hosting, že byste chtěli aktualizovat PHP, buď to provedou přímo na stávajícím serveru nebo web přesunou na nějaký jiný server s požadovanou verzí PHP. Nebo také občas napíšou, že dojde k aktualizaci teprve někdy v budoucnu, a pak můžete jedině změnit hosting. Jaký používáte hosting?

    #32618

    zjesu
    Participant

    Zdravím a oživuji tento dotaz.
    Active24 má volbu
    5.4.45
    5.5.38
    7.0.19
    Kterou verzi upřednostnit, případně proč?
    Děkuji.

    #32625

    admin
    Keymaster
    Web

    @zjesu: Rozhodně nejnovější 7.0.19, protože je nejrychlejší a nejbezpečnější :-) Pouze pokud narazíte na nějaký problém, tak se vracet k nějaké starší verzi…

    #32659

    zjesu
    Participant

    Děkuji @admin, tak nějak sem si to myslel. Malinko mě znejisťovalo, že hosting má primárně nastavenou nižší verzi :-)

    #32663

    admin
    Keymaster
    Web

    Většinou hosting nechává pro stávající weby nějakou verzi, na které původně fungovaly, ale jinak má myslím většina hostingů defaultně nastaveno pro nové weby PHP 7.x, je to i pro jejich dobro :-)

    #32664

    zjesu
    Participant

    @admin: děkuji za objasnění.

Aktuálně je na stránce zobrazeno 7 příspěvků - 1. až 7. (z celkem 7)

Pokud chcete odpovědět na toto téma, musíte se nejdříve přihlásit.