Poškozená šablona

Zvolené téma obsahuje celkem 6 odpovědí. Do diskuze (3 účastníci) se naposledy zapojil uživatel  admin a poslední změna je stará 5 let, 11 měsíců.

Aktuálně je na stránce zobrazeno 7 příspěvků - 1. až 7. (z celkem 7)
  • Autor
    Příspěvky
  • #19553

    Petr S
    Participant

    Ahoj, stáhl jsem šablonu na Themeforest a po instalaci mi to píše:

    Poškozené šablony
    Následující šablony jsou sice nainstalované, ale nejsou kompletní. Šablony musí obsahovat nejen soubor s kaskádovými styly (style.css), ale také nějaké konkrétní PHP soubory pro zobrazení příslušných dat.
    Název 	Popis
    Midway-WP-Theme 	Soubor s kaskádovými styly nebyl nalezen.

    Přesto se šablona jeví, že je v pořádku a je funkční(zatím nevím, jestli na 100%).
    Nevíte, čím to může být, popřípadě co s tím?

    Díky

    #19563

    mirekk
    Participant
    Web

    Šablona bude v pořádku. Pravděpodobně jste nahrál z toho zipu, který jste stáhnul z Themeforest všechno co v něm bylo že?
    Je potřeba z toho balíku vytáhnout jen ten kus, který má název šablony a v něm jsou její soubory. Že jste ve správném adresáři poznáte podle toho, že zpravidla první soubor má název 404.php, další bude archive.php
    Nahrajte tedy do /themes/ celý tento adresář a mělo by to být v pořádku

    #19574

    Petr S
    Participant

    Díky moc za odpověď. Šablonu jsem zkusil odinstalovat a nainstalovat zpět. Chyba je stejná(přesto šablona funguje). Zkusil jsem jí nahrát na jinou doménu a tam je vše v pořádku.
    Na původní doméně mi to hlásí další chybové hlášky:

    Warning: An unexpected error occurred. Something may be wrong with WordPress.org or this server’s configuration. If you continue to have problems, please try the support forums. (WordPress could not establish a secure connection to WordPress.org. Please contact your server administrator.) in /home/mysite/public_html/wp-admin/includes/update.php on line 117, 119, 287, 435.

    Dle diskuzí je to prý aktualizací WordPressu 3.9.1???

    #19586

    admin
    Keymaster
    Web

    To je podivné, nemůže to souviset s nastavením serveru? Jaký používáte hosting? Máte šablonu Midway oficiálně koupenou (a tedy aktuální verzi z dubna 2014) nebo jen někde staženou?

    Další chybové hlášky znamenají, že je nějaký problém v komunikaci mezi serverem (hosting) a API wordpress.org. Podle jakých diskuzí to souvisí s WordPressem 3.9.1?

    #19604

    Petr S
    Participant

    Šablona je oficiálně zakoupená přímo přes Envato marketplaces. Hosting Active24.
    Posílám odkaz na diskuzi http://wordpress.org/support/topic/error-when-upgrading-from-39-to-391….
    Díky.

    #19608

    admin
    Keymaster
    Web

    Tak to vypadá zajímavě :-) Automatická instalace pluginů a šablon (a jejich aktualizace) funguje bez problémů? Můžete poslat přístupy (administrátor WordPressu + FTP) na email pavelevap@separatista.net, zkusím se na to časem podívat. Zkoušel jste deaktivovat všechny pluginy a nasadit výchozí šablonu Twenty Fourteen? Nemáte nějaké speciální nastavení v souboru wp-config.php? Nepoužíváte nějaký bezpečnostní plugin?

    #19760

    admin
    Keymaster
    Web

    Pokud se problém stále objevuje, podívejte se prosím sem, kde naleznete návod, jak to řešit…

Aktuálně je na stránce zobrazeno 7 příspěvků - 1. až 7. (z celkem 7)

Pokud chcete odpovědět na toto téma, musíte se nejdříve přihlásit.