Next gen – nahrávání obrázků

Úvodní stránka Fórum podpory WordPressu Problémy s WordPressem Next gen – nahrávání obrázků

Zvolené téma obsahuje celkem 6 odpovědí. Do diskuze (2 účastníci) se naposledy zapojil uživatel  admin a poslední změna je stará 7 let, 9 měsíců.

Aktuálně je na stránce zobrazeno 7 příspěvků - 1. až 7. (z celkem 7)
  • Autor
    Příspěvky
  • #2578

    Jirik
    Participant
    Web

    Dobrý den, zajímavý úkaz. Když přes next gen nahraji fotku z pc kterou jsem graficky upravil tak se na webu zobrazuje ve stavu v jakém byla pořízena tedy bez úprav, ale v náhledu je zobrazen nový stav po úpravách. Kde dělám chybu? Díky za odpověď

    #13855

    admin
    Keymaster
    Web

    V čem spočívá grafická úprava obrázků? Nahrávané obrázky jsou zmenšovány pro náhledy a přitom také probíhají určité grafické operace, ale obvykle nelze moc rozpoznat rozdíl… Nemáte nějaký příklad původního obrázku a automaticky vytvořeného náhledu?

    #13856

    Jirik
    Participant
    Web

    Dobrý den, nakonec to bylo asi prohlížečem IE. Fotky jsem smazal ze srv a nahrál přes jiný prohlížeč FF a vše fungovalo. JIný problém s NEXT genem je však jinde.

    Včera jsem aktualizoval na 3.5 a ukazuje mi to hlášku viz http://www.stavitel-jf.cz/

    #13857

    admin
    Keymaster
    Web

    Warning: Missing argument 2 for wpdb::prepare(), called in /home/www/stavitel-jf.cz/subdomeny/www/wp-content/plugins/nextgen-gallery/lib/tags.php on line 318 and defined in /home/www/stavitel-jf.cz/subdomeny/www/wp-includes/wp-db.php on line 990

    Ano, to je jeden z častých problémů, které mají autoři pluginů s novou verzí WordPressu 3.5. Nahlášeno to bylo i pro plugin NextGEN Gallery a podle autorů by měla brzy vyjít aktualizace. A pokud s opravou spěcháte, tak na uvedeném odkazu naleznete dočasné řešení, které tento problém odstraní (úprava zdrojového kódu pluginu).

    Ad problém s obrázky v IE: Patrně to bylo nějaké cachování prohlížeče, těžko říci. Ale je to trochu podivné, protože náhledové obrázky automaticky vytvořené pluginem NextGEN Gallery by měly být unikátní a tedy by neměly být předtím nikde cachovány…

    #13858

    Jirik
    Participant
    Web

    Děkuji za odpověď.

    Teď bych si dovolil ukázku původního problému. Příspěvek viz http://www.stavitel-jf.cz/?cat=11 v náhledu je obrázek na kterém mají být vidět graficky červené šipky, ale po otevření je obrázek bez šipek a otočený jako v době pořízení. V FF je to v pořádku v IE není. Pročistil jsem všechny prohlížeče a smazal historii a přesto mi IE vyhazuje chybovost. Pokud je to i ve Vašem prohlížeči špatně tak je chyba v kodu. Pokud se vám to zobrazuje správně tak je to u mě na reinstal IE.

    #13859

    Jirik
    Participant
    Web

    Tak jsem následoval odkaz pro opravu hlášky a povedlo se hlášku odstranit. Je to soubor “nextgen-gallery/lib/tags.php” řádek 318, který se změní z podoby:

    $term_ids = $wpdb->get_col( $wpdb->prepare("SELECT term_id FROM $wpdb->terms WHERE slug IN ($sluglist) ORDER BY term_id ASC "));

    na:

    $term_ids = $wpdb->get_col( $wpdb->prepare("SELECT term_id FROM $wpdb->terms WHERE slug IN ($sluglist) ORDER BY term_id ASC ", null));

    #13860

    admin
    Keymaster
    Web

    Nová verze pluginu NextGEN Gallery 1.9.9 by měla tento problém definitivně vyřešit, stačí jednoduše automaticky aktualizovat.

    Podobný problém se řešil i zde a podle jednoho uživatele stačilo také resetovat nastavení pluginu (asi bez vymazání obrázků). Moc jsem to nezkoumal, ale je to trochu podivné…

Aktuálně je na stránce zobrazeno 7 příspěvků - 1. až 7. (z celkem 7)

Pokud chcete odpovědět na toto téma, musíte se nejdříve přihlásit.