Nejde instalace pluginu

Zvolené téma obsahuje celkem 2 odpovědi. Do diskuze (3 účastníci) se naposledy zapojil uživatel  admin a poslední změna je stará 4 roky, 3 měsíce.

Aktuálně jsou na stránce zobrazeny 3 příspěvky - 1. až 3. (z celkem 3)
  • Autor
    Příspěvky
  • #1498

    VikiT
    Participant

    Dobrý den
    Jsem absolutní nováček ve WordPressu, proto mám asi laický dotaz, ale poprosím o reakci.

    Když dám install Pluginu – jakéhokoliv tak mi vyhodí chybovou hlášku:
    Warning: posix_getpwuid() has been disabled for security reasons in /home/www/chciparit.cz/subdomeny/www/wp-admin/includes/class-wp-filesystem-direct.php on line 172

    Jedná se o WP 3.3.1 děkuji za radu

    #10945

    neteyescz
    Participant

    Dobrý den,

    Pravděpodobně jde o problém s Vaším hostingem, protože funkce zmíněná v ErrorLogu je funkcí PHP (Manuál). Tato funkce však není na všech hostinzích povolena. Podle mých informací jde o funkci, jež vrací jméno uživatele podle jeho ID a pro běh WP je tudíž důležitá. Napište, prosím, tedy Vašemu poskytovateli hostingu, aby danou funkci zapl. Pokud se tak nestane, nejspíše Vám nezbude nic jiného, než se poohlédnout jinde. Pokud bych Vám měl doporučit hosting, kde WordPress funguje jako po másle, tak doporučím Wedos. Napište sem, pokudmožno hosting, na kterém to nefunguje, aby se ostatní poučili.

    #24331

    admin
    Keymaster
    Web

    @vikit: Sice otevírám už dost staré téma, ale podařilo se to nakonec nějak vyřešit? Podobná hláška se nám teď objevuje právě u Wedosu, patrně pouze s PHP 5.6. O jaký šlo hosting? Vzhledem k datu tohoto tématu asi nešlo o PHP 5.6 :-)

    Patrně byla funkce z bezpečnostních důvodů zakázána, ale WordPress měl ošetřeno její použití i ve staré verzi 3.3.1, takže se popisovaná chyba asi projevila i v nějaké starší verzi PHP s instalovaným OPcache (či nějaké jiné kombinaci)…

Aktuálně jsou na stránce zobrazeny 3 příspěvky - 1. až 3. (z celkem 3)

Pokud chcete odpovědět na toto téma, musíte se nejdříve přihlásit.