Nefunkční odkazy v rámci sítě

Úvodní stránka Fórum podpory WordPressu Problémy s WordPressem Nefunkční odkazy v rámci sítě

Zvolené téma obsahuje celkem 7 odpovědí. Do diskuze (2 účastníci) se naposledy zapojil uživatel  Roman a poslední změna je stará 10 let, 2 měsíce.

Aktuálně je na stránce zobrazeno 8 příspěvků - 1. až 8. (z celkem 8)
  • Autor
    Příspěvky
  • #6670

    Roman
    Participant

    Dobrý den,

    tvořím ve firmě intranet pomocí wordpressu a narazil jsem na problém. Snažím se ho vyřešit už cca 2 měsíce, ale stále nic.

    Jedná se o to, že když v příspěvku (stránce) vytvořím odkaz na síťový disk (\serversložkasoubor.abc), tak na stránkách v prohlížečí IE po kliknutí na odkaz se neděje vůbec nic (odkazy do internetu fungují normálně). Když dám ale pravým tlačítkem na odkaz a uložit cíl jako…, tak se mě to zeptá, kam chci soubor uložit, takže odkaz tam opravdu je. Když zadám ručně do URL prohlížeče cestu k tomu souboru (kam odkazuje ten odkaz), tak mi to klasicky vyhodí okno, jestli chci otevřít, nebo uložit. To je všechno v pořádku, ale po kliknutí na odkaz se nestane nic.

    Důležitá poznámka ale také je to, že na většině ostatních PC ve firmě se po kliknutí odkazy chovají normálně (zobrazí okno s nabídkou). Ty PC, na kterých to nejde, jsou 2 a jedná se o Dell optiplex 7010. Otestoval jsem tu těhle Dellů 9 a na 7 PC to jde, na 2 ne. Zkusil jsem veškerý SW z PC, kde to funguje normálně, nainstalovat i na PC, kde to nejde a nepomohlo to. Dodám, že na všech PC je vypnutý firewall a všude je OS Windows 7 Professional.

    Další zajímavost je ta, že když exportuji databázi a poté ji importuji na localhost, tak na localhostu odkazy fungují normálně.

    Už opravdu nevím, co bych měl udělat :-(

    Děkuji za rady

    R.M.

    #17925

    ScheRas
    Participant
    Web

    Je na všech počítačích stejná verze IE? Jsou všechny prohlížeče stejně nastavené? V jiných prohlížečích to funguje? Ve firebugu (konzoli pro vývojáře) se při kliknutí na takový odkaz nezobrazí nic zvláštního? Zkoušel jste koukat do hosts popřípadě do jiného podobného nastavení? Nebokuje tyto počítače přímo server na kterém to běží?

    #17926

    Roman
    Participant

    Stejná verze IE na všech počítačích není, jsou tu IE9 a IE10, ale na obou verzích to funguje (na tich 2 PC, kde to nefunguje, je IE10).

    Nenašel jsem nic, co by bylo odlišně nastavené, jedná se o předinstalovaný Win 7 a v IE pouze přidán proxy server.

    Zkoušel jsem ve Firefoxu, ten si ale neporadí s formátem \serversložkasoubor.abc a když udělám odkaz formou P:složkasoubor.abc, tak si Firefox automaticky po kliknutí převede velké písmeno P na malé písmeno p a pak zobrazí chybu (když manuálně přepíšu v URL prohlížeče malé p na velké P, tak to funguje).

    Dále jsem zkoušel Chrome a ten se chová stejně jako IE, tudíž po kliknutí se nestane vůbec nic.

    V konzoli pro vývojáře se po kliknutí také nestane nic zvláštního.

    Kde najdu ten hosts a co to vůbec je? :-)

    Nevím nic o tom, že by přímo server nějaké PC blokoval.

    R.M.

    #17927

    Roman
    Participant

    Tak v hosts mám pouze localhost.

    127.0.0.1 localhost

    A vlastně ještě jako komentář, takže tam není nic.

    #17928

    ScheRas
    Participant
    Web

    A odkaz formou file://?

    #17929

    Roman
    Participant

    Zkoušel jsem snad všechny možné způsoby zadávání odkazu. Obyčejná lomítka, zpětná lomítka, file://… a nic nefunguje.

    #17930

    Roman
    Participant

    Nikdo nevíte, čím by to mohlo být? :-(

    #17931

    Roman
    Participant

    A nebo je ještě prosím nějaká možnost, jak z webu odkazovat na síťový disk?

    Je to opravdu důležité, potřebuju udělat web, ze kterého budou zaměstnanci přistupovat k souborům na síťovém disku, ale přes odkazy to na 3 PC nefunguje :-(

Aktuálně je na stránce zobrazeno 8 příspěvků - 1. až 8. (z celkem 8)

Pokud chcete odpovědět na toto téma, musíte se nejdříve přihlásit.