Nefunguje instalace pluginu

Úvodní stránka Fórum podpory WordPressu Hosting a WordPress Nefunguje instalace pluginu

Štítky: ,

Zvolené téma obsahuje celkem 2 odpovědi. Do diskuze (2 účastníci) se naposledy zapojil uživatel  mansur a poslední změna je stará 7 let, 10 měsíců.

Aktuálně jsou na stránce zobrazeny 3 příspěvky - 1. až 3. (z celkem 3)
  • Autor
    Příspěvky
  • #27350

    mansur
    Participant

    Prosím o radu. V adminu standardně instaluji nový plugin z nabídky, odkliknu tlačítko instalace u vybraného pluginu a zobrazí se známá stránka s názvem Instalace pluginu: “název pluginu”. Stránka však zůstane nadále prázdná, nezobrazí se příslušné řádky včetně nabídky aktivace pluginu. Neobjeví se ani žádná chybová hláška nebo dialog. Tento stav se trvale nemění, přitom dříve instalace proběhla během 5 sekund. Stejně tak se admin chová při instalaci šablony.

    Zkusil jsem ručně přes webFTP, po odkliknutí finálního kroku, však FTP spadl a instalace se neprovedla. FTP má tendenci padat a objevuje se chybová hláška error occured in file /srv/www/htdocs/net2ftp.com/includes/filesystem.inc.php on line 56. Na FZ jsem se k serveru nepřipojil, FZ hlásil chybu 500 OOPS: setuid. Ale po chvíli se vždy na webFTP připojím. Upravil jsem si config, aby se mi v contentu zobrazoval debug.log s hlášením chyb. Tam se nyní hlásí toto: Starý systém číslovaných uživatelských úrovní používaný v pluginech a šablonách již není nadále podporován. Použijte místo něj raději současné uživatelské úrovně fungující na základě přidělování jednotlivých pravomocí. in /data/web/virtuals/119939/virtual/www/wp-includes/functions.php on line 3846

    Díval jsem se tedy do souboru functions.php a zde k danému řádku patří buď

    * @param mixed $data Variable (usually an array or object) to encode as JSON.

    nebo

    * @param int $depth Maximum depth to walk through $data. Must be greater than 0.

    Možná, že celý problém souvisí s aktualizací na nový WP, protože po něm instalace přestala fungovat.

    Pokud problém vyžaduje úpravu v functions.php, prosím o radu.

    #27367

    admin
    Keymaster
    Web

    Jakým způsobem jste provedl aktualizaci na nejnovější verzi WordPressu (ručně či automaticky)?

    Jako první prosím zkuste zprovoznit FTP (např. prostřednictvím programu Filezilla). Přístup na FTP musí být funkční a rychlý, kdyby se něco někde pokazilo, tak to pomocí FTP můžete ručně zachránit. Pokud tam jsou stále výpadky, tak to nahlašte na podporu hostingu. Jaký hosting používáte?

    #27385

    mansur
    Participant

    Díky. Aktualizace na nejnovější verzi WP byla provedena automaticky v adminu. Hosting je wedos. Přístup na webFTP již hoster stabilizoval, zde již není problém a běží bez výpadků. Plugin Wordfence jsem nahrál ručně přes webFTP a v adminu aktivoval. Bohužel ale nefunguje, zobrazuje se prázdná stránka bez nějakého hlášení chyby. V debug.logu není hlášení, že by chyběl nějaký soubor, jak se může při ruční instalaci přes webFTP stát. Chtěl jsem rovněž v adminu aktivovat plugin WP doctor, to však nešlo vůbec. Poté nešlo se už přihlásit na přihlašovací stránce WP do adminu a hlásilo to chybu v tom smyslu, že není povoleno cookies pro tuto stránku. V nastavení firefoxu však bylo vše v pořádku. Zkusil jsem tedy přes webFTP vymazat WP doctor, jenž stejně nešlo aktivovat, a náhle se už šlo na přihlašovací stránce WP přihlásit do adminu. Něco je tam zřejmě špatně s pluginy. Kdybych věděl, který soubor toto řídí, mohl bych ho vyměnit, třeba je poškozený..

Aktuálně jsou na stránce zobrazeny 3 příspěvky - 1. až 3. (z celkem 3)

Pokud chcete odpovědět na toto téma, musíte se nejdříve přihlásit.

WordPress – novinky, návody a zajímavosti