Lightbox 2

Zvolené téma obsahuje celkem 19 odpovědí. Do diskuze (5 účastníků) se naposledy zapojil uživatel  misakralicek a poslední změna je stará 9 let, 1 měsíc.

Aktuálně je na stránce zobrazeno 20 příspěvků - 1. až 20. (z celkem 20)
  • Autor
    Příspěvky
  • #986

    misakralicek
    Participant
    Web

    Nevím proč, ale nefunguje mi plugin Lightbox 2 na zobrazení obrázků. Problém je že třeba v tomto článku nefunguje na žádný obrázek v článku: http://goo.gl/DElHW. Na jiném článku zase funguje vždy bez problému př.: http://goo.gl/vxu7Q. Strýček google mě stále radí cosi o prohazování řádků v JavaScriptech. Nevím mě příjde že jich tam je nějak moc ale vůbec tomuhle oboru nerozumím a nedokážu se v něm orientovat, takže prosím, kdybyste věděli co s tím tak nějak po lopatě :D Mě se tenhle Plugin líbí pro svou ucelenost a praktičnost, teda když funguje… :D :( Proto bych u něj chtěl zůstat, takže pokud bychom to nějak vyřešily jednou pro vždy, byl bych vám moc vděčný.

    Díky

    #8398

    admin
    Keymaster
    Web

    Podobný problém s pluginy pro hezké zobrazování obrázků se tu objevil nedávno. A plugin Lightbox 2 v tomto případě fungoval. Je tam i trochu popsaný návod na zprovoznění a možné problémy. Obecně bývají problémy nejčastěji způsobeny právě konfliktem JavaScriptů (vyzkoušejte deaktivovat všechny pluginy).

    Pokud to ale jde u jednoho příspěvku a u jiného zase ne, tak to může být i šablonou nebo pluginem, který se spouští selektivně pouze pro nějaké příspěvky či rubriku. Ale je to rozhodně zvláštní – u spousty příspěvků to jde a jen u toho jednoho ne (i když to začne “jakoby” nabíhat). Případně může jít o nějaké “podivné” HTML nebo jinou “vadu” samotného příspěvku. Nefunguje to ještě u nějakého jiného příspěvku? Nebyl u toho příspěvku ještě nějaký další problém (např. byl publikován v době kdy plugin Lightbox 2 ještě nebyl aktivován – i když to by měl plugin asi řešit)? Nebo když ty obrázky vložíte do nějakého jiného příspěvku, tak tam s nimi plugin Lightbox 2 funguje (a tedy není problém v obrázcích)?

    #8399

    misakralicek
    Participant
    Web

    Ano ten článek ve foru jsem pročítal, ale obracím se znovu protože tam je sice jakási metoda na zapsání tagu do všech obrázků .. ale je to taková neslaná metoda na plnohodnotné čisté zfunkčnění všech obrázků na webu…. Jinak ano máte pravdu i u nových příspěvků by měl fungovat ale ano myslím že i u nějákého staršího (http://goo.gl/HI2up) to nefungovalo a není to s žádnou periodou opakování problému ale spíše občas jeden.. ale je to otravné .. a ještě jednou ano máte pravdu začne se načítat ale hned vyskočí do okna samostatně.. nechápu to… máte nějáký nápad?

    Děkuji :)

    #8400

    admin
    Keymaster
    Web

    Je to podivné, ale nápady jsem uváděl výše:

    – Deaktivovat všechny ostatní pluginy. Stále to nefunguje?

    – Co nasazení výchozí šablony Twenty Ten?

    – Zkuste vložit galerie (obrázky), kde to nefunguje do nějakého zcela nového testovacího příspěvku. Jakým způsobem tam vlastně obrázky vkládáte? To je nějaká galerie? Díval jsem se a nejsou umístěny ve standardním adresáři wp-content/uploads.

    – Pokud nic z toho nepomůže, tak pošlete administrátorské přihlašovací údaje do WordPressu na email pavelevap@separatista.net, zkusíme se na to podívat.

    #8401

    Lukenzi
    Participant

    Pokud vypnutí pluginů nepomůže zkusil bych ještě něco. Jediný rozdíl ve zdroji je totiž jen v tom, že tam kde to funguje jsou obrázky obaleny do HTML tagu <div>...</div> a tam kde ne jsou jen v nějakém pofidérním <span style... . Takže bych se zkusil přepnout do HTML editoru a upravit to ať jsou ty obrázky obaleny jen s <div>...</div>.

    #8402

    admin
    Keymaster
    Web

    Lukenzi: Toho jsem si také všiml, ale u jednoho příspěvku byl také div a nefungovalo to, což mě docela zmátlo… Ale možná to bude nějaká kombinace podivného HTML, i když plugin by měl přidávat atribut rel pouze ke značce img, takže by ho nic jiného asi nemělo zajímat… Každopádně je to docela zajímavé, zkusím se ještě podívat na zdrojáky pluginu…

    #8403

    misakralicek
    Participant
    Web

    Děkuji za vaše reakce, na pročištění kodu se podívám, je možné že kopírováním “layoutu” pro články se mi podařilo kod obalit nějakými nepotřebnými věcmi, každopádně jsem vyzkoušel vypnout pluginy a nepomohlo to. A pokud vím tak “Lightbox 2” jako takový nepřidává atributy rel, ten se přidává pouze ručně pokud to jinak nerozpozná sám. Možná jsem jen nepochopil přesně vaši reakci, ale myslím že to plugin jako takový nepřidává do kodu každého obrázku. Vyzkoušel jsem i zapnutí defaultní šablony, také nepomohlo.

    #8404

    misakralicek
    Participant
    Web

    Tak ani v kodu článku jsem neoběvil nic co by situaci změnilo, opravdu netuším co s tím, na internetu se pár reakcí podobného typu oběvuje, ale nějakou srozumitelnou odpověď jsem v nich bohužel nenašel. Za každý další tip budu velice rád.

    #8405

    Lukenzi
    Participant

    je to zvláštní…jinak já třeba používám Simple Lightbox, ten je sice pořád označován jako beta verze, ale funguje bez problémů a je i dost často aktualizovaný. V nastavení můžeš určit zda se obrázky mají zobrazovat samostatně nebo třeba jako slideshow pokud je jich v článku víc. Pokud se to nevyřeší tak zkus tento plugin.

    #8406

    misakralicek
    Participant
    Web

    Dobrý tip, vzhledem k designu se mi to líbí protože je to dost podobné a pokud je to funkční i přes slovo “beta” tak asi přejdu pokud ještě někdo nepřijde na polaďění “LIGHTBOX 2”. Jen trochu mimo,Lukenzi děkuji za článek o větším zabezpečení WP hned se na to vrhnu :D

    #8407

    misakralicek
    Participant
    Web

    Začal jsem využívat Simple Lightbox, který má opravdu mnohem větší smysl nabízí obrovské možnosti nastavení a můžu jej jen doporučit. Problém je, nevím jestli se se s tím setkaly, že když se fotografie zvětší tak i když je nastaveno aby pokud je fotografie velkých rozměrů došlo ke zmenšení na danou obrazovku, tak se fotografie přizpůsobuje ze šířky což je nepraktické a tudíž i docela špatně vyřešené třeba u fotek na výšku kde je to nejvíce vidět, nebo u fotek které prostě výškou přesahují obrazovku dotyčného surfaře. Manuální zmenšení fotografií pro mne není řešením, máte tedy nějaký nápad? nebo jsem něco nastavil špatně. :)

    #8408

    misakralicek
    Participant
    Web

    Tak možná menší omyl, ono to nezmenšuje vůbec :D Použil jsem menší okno i menší monitor na notebooku a zjistil jsem, že nedochází k automatickému přizpůsobení podle uživatelova okna. Znovu se tedy ptám jestli nemáte nějakou možnost nebo nápad jak toto vyřešit. Děkuji

    #8409

    Artemian
    Participant
    Web

    Co se týče Lightbox2…

    Když vložíš obrázek (z odkazu, nahraješ ho do systému, atd…) otevři v článku jeho nastavení, a ujisti se že je u něj nastaven “Odkaz na obrázek” (nikoliv na obrázek jako na přílohu) a pak se ujisti, že v REL toho obrázku je vepsáno lightbox. Teprve potom začnou obrázky vyjíždět ;-)

    #8410

    misakralicek
    Participant
    Web

    Ano, u lightbox 2 jsem měl nastaveno přímí odkaz na obrázek ne jen na další odkaz vedoucí na další náhled a v RELu jsem němel nikdy nic vepsáno a fungovalo to, to je právě to proč je u tohoto pluginu možnost automatické aktivace u všech obrázků, zde tedy řešíme proč to dělá jen u některých.. samozřejmě se správným REL kodem to funguje správně vždy. Problém je že tohle nejde zadávat manuálně u sto obrázků a plugin na dopisování není taky vhodný pro mne. Spíš šlo o to tu vyřešit problém s tím že některé články to ignorovalo a některé ne.

    #8411

    neteyescz
    Participant

    Problém má vždy nějákou logiku, zkuste se tedy podívat v čem se články kde se to neaplikuje liší od ostatních…

    #8412

    misakralicek
    Participant
    Web

    Já to snad nevyřeším, ty člínky mají stejnou dokonce zkopírovanou strukturu a pouze jsem vymazal obrázky a nahrál nové vše je tedy stejné, ale to nějak zfunkčnil a pomohl mi vámi zde doporučený Simple Lightbox, který ale zase nezmenšuje obrázky podle velikosti uživatelovy obrazovky a navíc nefunguje na fotografie které jsou v galerii tvořenou jedním klikem wordpresem , na jednotlivě vkládané to funguje na kolekce (galerie) ne. Takže asi využiji ještě jquery colorbox který sice není tak pěkný ale má tunu nastavení a funguje bez problémů všude… tudíž takhle to sice pěkně zaplácnu jen jsme to zde moc nevyřešily každopádně děkuji alespoň za rady.

    #8413

    neteyescz
    Participant

    A máte pro galerie použitý nějáký ext. plugin ?

    #8414

    misakralicek
    Participant
    Web

    Ne nemám, jde přímo o tu integrovanou ve WP. Situace se však trochu pohnula, již jsem zkontroloval všechny články, s prvním problémem s lightbox 2 kdy zobrazoval lightobox jen některé obrázky a některé dával normálně do nového okna jako by tam plugin nebyl, jsem si poradil jen tím že právě najitím problémových článků a jejich přepsáním stylu že jsem vzal článek vymazal jsem celé jeho HTML čímž jsem nepřišel o použité štítky a ostatní nastavení například zařazení do rubrik datum vydání apodobněo a podle staré verzi jsem celý obsah po částech překopírovával, kontroloval přes náhled funkčnost obrázků kdyby některá část článku zlobila abych se na ní podíval, a řešení celé této situace tedy je takové, že pokud vám to dělá tak jako mě tak vemte celý článek a přepiště ho nebo překopírujte ze starého postupně znovu. Vše zatím jede v pohodě, byla tedy chyba někde v html tech článků, kterou jsem nedokázal najít. Tento proces mi však proces hledání v html chyby nahradil. Vše tedy již čistě funguje, zbývá již jen zbytek tech několik “vadných” článků přepsat (překopírovat) znovu a bude vše OK. Všem děkuji za rady a postřehy, určitě jsem se zase něco nového naučil.

    #8415

    admin
    Keymaster
    Web

    misakralicek: Zajímavé, HTML jsme podezírali již na začátku. Dobrou pomůckou je při kopírování textu do vizuálního editoru používat tlačítko “Vložit jako neformátovaný text” (druhá řada editoru). Nedostane se vám pak do příspěvku žádné nepěkné HTML.

    Nemáte ještě nějaký neopravený příklad? Nemůžete nám pak poslat přístupy do administrace na email pavelevap@separatista.net? Zkusili bychom konkrétní příspěvek prohlédnout a nalézt konkrétní příčinu tohoto problému…

    #8416

    misakralicek
    Participant
    Web

    Dobře kdyby něco napíšu, zatím jsem vše zprovoznil.

Aktuálně je na stránce zobrazeno 20 příspěvků - 1. až 20. (z celkem 20)

Pokud chcete odpovědět na toto téma, musíte se nejdříve přihlásit.