Jak zabránit automatické aktualizaci?

Domů Fórum podpory WordPressu Problémy s WordPressem Jak zabránit automatické aktualizaci?

Zvolené téma obsahuje celkem 4 odpovědi. Do diskuze (3 hlasy) se naposledy zapojil uživatel  topcz a poslední změna proběhla před 2 měsíců, 2 týdnů.

Prohlížíte 5 příspěvků - 1 z 5 (z 5 celkově)
  • Autor
    Příspěvky
  • #33630

    topcz
    Účastník
    Web

    Každá nová aktualizace čehokoliv na Internetu, přináší nové problémy. Alespoň mně. Místo, aby to pomohlo a zjednodušilo práci, zpravidla to přinese nějaký problém. Koupil jsem nový PC-Lenovo All-in-online. Po 3 měsících šel v záruce na opravu DVD mechaniky. Taková blbost, kterou bych si udělal sám, kdyby to nebylo v záruce. Závěr – oprava 30 dnů, přeinstalovaný Win8 na Win 10 a tím tři pr*ele nových problémů. Do nedávna jsem používal WP 4.6.4. Neměl jsem žádné problémy. Pak se mi automaticcky aktualizoval na 4.6.6. a začaly problémy. Denně “Error Log” o objemu 16 MB (dlouhý jak pracovní týden), hlavní závada – “Moře čísel, které neuvedu ale – Chyba datab\xc3\xa1ze WordPressu: Table ‘db31363xwp.post2cat’ doesn’t exist”. Nikdy jsem žádnou tabulku “post2cat” neměl a ani nevěděl kde ji a jak udělat. Trvalo mi 3 dny, než jsem zjistil příčinu. Musel jsem deaktivovat všechny pluginy a postupně po jednom aktivovat, pak testovat atd., až jsem zjistil, že to dělá plugin “Post by Category”. Po deaktivaci tohoto pluginu se LOG podstatně zmenšil, ale stále mi to píše dvě závady s kteými nemohu hnout. Zase uvedu bez čísel v předu, jen text:
    “AH00124: Request exceeded the limit of 10 internal redirects due to probable configuration error. Use ‘LimitInternalRecursion’ to increase the limit if necessary. Use ‘LogLevel debug’ to get a backtrace”.

    “(32)Broken pipe: [client 83.240.11.141:59996] mod_fcgid: ap_pass_brigade failed in handle_request_ipc function, referer websurf.cz”

    Má někdo páru o tom, co to může znamenat a co je příčinou těcch error logů?
    Ani jednu z těch závad mi to u verze 4.6.4 nepsalo a jak lze vypnout ty automatické aktualizace WP. Kdyžý tu příčinu nenajdu, vrátim WP do verze 4.6.4, ale potřebuji zakázat automatickou aktualizaci na 4.6.6. Díky za každou radu.

    #33633

    mirekk
    Účastník
    Web

    vložte do wp.config.php:řádek

    define( 'AUTOMATIC_UPDATER_DISABLED', true );

    na místo v obrázku:

    Attachments:
    #33637

    topcz
    Účastník
    Web

    Díky.
    vm

    #33640

    Michal Janata
    Účastník
    Web

    Šťastné řešení to není. Ty malé verze řeší opravy chyb, přes které se vám může do webu kdokoliv dostat. Není ten plugin zastaralý?

    #33642

    topcz
    Účastník
    Web

    Díky za připomínku, ale nevím, jaký plugin máte na mysli. Já jsem ten plugin, který dělal ty obrovské záznamy (Post by Category) již vyhodil, ale pořád mi to dělá již jen tyto dva menší záznamy: (moře čísel před textem-datum, čas, IP adresa atd. a text:
    ——————
    “AH00124: Request exceeded the limit of 10 internal redirects due to probable configuration error. Use ‘LimitInternalRecursion’ to increase the limit if necessary. Use ‘LogLevel debug’ to get a backtrace”.
    ——————–
    “(32)Broken pipe: [client 83.240.11.141:59996] mod_fcgid: ap_pass_brigade failed in handle_request_ipc function, referer websurf.cz”
    ——————

    To zpětvrácení do verze 4.6.4., podle rady kolegy nahoře nemohu nějak udělat. Když jsem otevřel wp-config.php, tak tam ty řádky, co jsou na screenu od kolegy vůbec nemám. Takže nevím, jaký wp-config má kolega, protože já jsem si otevřel jak z verze 4.6.4., tak i z 4.6.6 a 4.6.8 a ty soubory jsou stejné, ale ty doporučeny řádky tam nejsou. Viz screen v příloze. Jelikož jsem nezjistil, že b to s webem cokoliv dělalo, udělám to, co mi poradila podpora webhostingu – vypnu logy a bude po ptákách. Díky za Váš čas a radu.

    Attachments:
Prohlížíte 5 příspěvků - 1 z 5 (z 5 celkově)

Pro reakci na tento článek se musíte přihlásit.