Ignorace HTML kódu

Zvolené téma obsahuje celkem 1 odpověď. Do diskuze (2 účastníci) se naposledy zapojil uživatel  admin a poslední změna je stará 2 roky.

Aktuálně jsou na stránce zobrazeny 2 příspěvky - 1. až 2. (z celkem 2)
  • Autor
    Příspěvky
  • #33881

    Tom Key
    Participant

    Vizuální editor má sice záložku HTML, ale základní HTML značky ignoruje a maže. Např <br /> po vložení a následném přepnutí do Editoru zcela vymazal. Také &nbsp;
    A když už text v Editoru ručně odřádkuju, a uložím, v konečném náhledu je všechno nasekáno za sebou, nadpis nenadpis. Prostě bramboračka. Neví někdo co s tím? Používám šablonu Everest Pro, jejíž součástí je Builder, ve kterém je použit klasický Vizuální editor.

    #33882

    admin
    Keymaster
    Web

    1) Mizení &nbsp; způsobuje tuším vizuální editor TinyMCE, který je mění na klasické mezery a následně jsou zcela smazány (podrobnosti). Jednoduché řešení je deaktivace vizuálního editoru v nastavení uživatelského profilu, případně můžete zkusit toto.

    2) Mizení odřádkování pak zase způsobuje funkce wpautop(), které čistí HTML, aby tam byly správné odstavce, atd. V podstatě je to tak správně, protože v editoru nemáte řešit vzhled příspěvku, ale jeho obsah a vzhled si můžete nadefinovat v rámci CSS. Takže si můžete nadefinovat třeba třídu .posun, která bude mít padding-bottom třeba 50px a pak ji v editoru použít. Zabránit tomu umí plugin TinyMCE Advanced, případně se to obchází zápisem <br class="mezera" />.

    Jakou šablonu přesně používáte? Catch Everest Pro? Můžete zkusit, zda to také nějak neovlivňuje, a to tak, že ji na zkoušku deaktivujete…

Aktuálně jsou na stránce zobrazeny 2 příspěvky - 1. až 2. (z celkem 2)

Pokud chcete odpovědět na toto téma, musíte se nejdříve přihlásit.