Diakritika u obrázků

Zvolené téma obsahuje celkem 5 odpovědí. Do diskuze (3 účastníci) se naposledy zapojil uživatel  mach44 a poslední změna je stará 2 roky, 11 měsíců.

Aktuálně je na stránce zobrazeno 6 příspěvků - 1. až 6. (z celkem 6)
  • Autor
    Příspěvky
  • #23516

    RK
    Participant

    Zdravím,
    u jednoho webu jsem narazil na velké množství obrázků u příspěvků, které mají diakritiku, obrázky se zobrazují, ale Google je nemůže indexovat vzhledem k tomu, že obsahují právě háčky, čárky a tudíž po zavolání to vypíše 404 – lze to nějak hromadně opravit, tak abych nemusel název obrázku upravit ručně přes FTP a poté je u příspěvku znovu zvolit?

    Děkuji.

    #23522

    admin
    Keymaster
    Web

    WordPress by měl obrázky s diakritikou zobrazovat bez problémů, chyba 404 by se tam neměla objevit. Používáte nejnovější verzi WordPressu? Nemáte nějaký konkrétní příklad obrázku (nebo alespoň jeho názvu), který nefunguje? Často se tento problém objevuje při přesunování webu na nový hosting (např. zde), nedošlo tam k nějakému přesunu?

    #23527

    RK
    Participant

    Nejnovější WP mám, problém je následující – pokud ke článku přidám obrázek s diakritikou, přidá se a normálně u příspěvku zobrazuje, ale když se mrknu do zdrojového kódu, obrázek (jeho cesta) je s diakritikou /wp-uploads/2015/../tohle-je-obrázek-pěkný.jpg a tím pádem jej Google neindexuje jelikož po kliknutí na cestu vyskočí chyba 404.

    Samozřejmě už přidávám obrázky bez diakritiky, ale zhruba 100 starých obrázků je potřeba opravit a ručně je to na dlouho, proto hledám způsob jak to opravit automaticky, nebo aspoň rychleji :-)

    Děkuji.

    #23537

    admin
    Keymaster
    Web

    Tak to je dost podivné, protože to by mělo fungovat. Schválně jsem zkusil nahrát obrázek s diakritikou a bez problém ho lze zobrazit:

    https://www.separatista.net/wp-content/uploads/2015/06/Žluťoučký-kůň.jpg

    Jaký používáte hosting?

    #23546

    RK
    Participant

    Díval jsem se na GWT a mám tam všechny obrázky s diakritikou jako chybové, že je Google nemohl nalézt, prošel jsem kód, a všechny tyto obrázky opravdu v pořádku fungují – ale proč je Google nemůže procházet opravdu netuším, ale nejde o nic zásadního takže to nechám plavat :-)

    Děkuji za odpovědi!

    #28226

    mach44
    Participant

    Dělá nám to něco podobného na webu, ale jen v Safari, v ostatních prohlížečích to jede bez problémů. Dobře je to vidět tady

Aktuálně je na stránce zobrazeno 6 příspěvků - 1. až 6. (z celkem 6)

Pokud chcete odpovědět na toto téma, musíte se nejdříve přihlásit.