BackWPup – zálohování pro WordPress

Úvodní stránka Fórum podpory WordPressu Pluginy (funkčnost webu) BackWPup – zálohování pro WordPress

Zvolené téma obsahuje celkem 11 odpovědí. Do diskuze (3 účastníci) se naposledy zapojil uživatel  admin a poslední změna je stará 1 rok, 4 měsíce.

Aktuálně je na stránce zobrazeno 12 příspěvků - 1. až 12. (z celkem 12)
  • Autor
    Příspěvky
  • #20631

    Lubos237
    Participant

    Mám nastavenu automatickou zálohu přes plugin BackWPup do DropBoxu. SQL databázi to uloží bez problémů, když to dělá zálohu souborů a chce to sbalit do zipu tak pošle na mail tuto chybu:

    1. Trying to create backup archive … [10-Říj-2014 03:01:58] Compressing files as ZipArchive. Please be patient, this may take a moment. [10-Oct-2014 01:03:17 UTC] PHP Fatal error: Maximum execution time of 20 seconds exceeded in /mnt/data/accounts/l/lubos237/data/www/vysokorychlostni-zeleznice.cz/wp-content/plugins/backwpup/inc/class-job.php on line 1638 [10-Říj-2014 03:03:17] ERROR: Maximum execution time of 20 seconds exceeded

    V dropboxu je přesto zip soubor uložen. Nevíte někdo, co ta chyba znamená? Zda to vůbec něčemu vadí? Pokud bych chtěl zazipovaný soubor použít pro obnovení webu, nebudu mít problémy?

    Děkuji!

    L.

    #20634

    admin
    Keymaster
    Web

    Plugin BackWPup používám a nikdy jsem takový problém neměl. Jaký používáte hosting? Jak velký je zálohovaný soubor? Máte také vcelku nízkou hodnotu pro maximální dobu spuštěného skriptu aneb max_execution_time (nastavení PHP na serveru).

    Osobně dávám do zálohy pouze databázi (potřebné tabulky) a provedené úpravy šablon (či vlastní pluginy). Pokud je na webu mnoho obrázků, tak je možné odškrtnout, aby se nezálohovaly všechny vygenerované velikosti (můžete je pak po ztrátě dat případně znovu vygenerovat).

    Zkuste zálohovaný soubor stáhnout a otevřít a uvidíte, zda tam je všechno, co by tam mělo být…

    #20673

    Lubos237
    Participant

    Hosting používám Savana Multihosting. Soubor má velikost: 3946 Files with 85,04 MB.

    Maximální dobu spuštěného skriptu aneb max_execution_time jsem dnes zvýšil z doporučovaných SAVANOU 20s na 40s. Nevím kolik je optimum, protože u nastavení zase píšou: nedávejte hodnotu příliš velikou, aby aby nedošlo k zablokování VPS serveru.

    Jak je možné odškrtnout, aby se nezálohovaly všechny vygenerované velikosti? Nenašel jsem to nikde v nastavení Jobs pluginu BackWPup. Předpokládám, že bych si nechal zálohovat jen tu největší velikost souboru. Proč vůbec WP ukládá tolik velikostí obrázků? Pochopil bych pokud by uložil pouze náhled + originální velikost.

    #20680

    admin
    Keymaster
    Web

    A nyní už to tedy funguje?

    Když se nechává maximální doba spouštěného skriptu příliš vysoká, tak to může způsobovat problémy v případě používání nekorektních skriptů (nebo příliš vysoké návštěvnosti). Ale u hostingů je nastaveno obvykle 30 – 90 sekund, takže by to asi neměl být problém, uvidíte…

    Když nastavujete/upravujete zálohovací Job, tak tam je záložka “Files”, kde je dole část “Exclude from backup” a tam můžete zaškrtnout “Don’t backup thumbnails from the site’s uploads folder.”. Podle mě by to mělo ignorovat automaticky generované náhledy, ale nikdy jsem to vlastně neprověřoval :-)

    WordPress ukládá původní obrázek + 3 různé náhledy (menu Nastavení – Média). Pokud se ukládá náhledů více, tak je to patrně kvůli nějakému pluginu či šabloně.

    Důvodem generování náhledů je fakt, že jejich vygenerování a odložení na FTP hned na začátku je “levnější” než aby to bylo prováděno až při zobrazování na webu (došlo by ke zpomalování načítání stránky).

    #20688

    Lubos237
    Participant

    Chybová hláška z BackWPup (po včerejším zvýšení max_execution_time na 40s) už dnes nepřišla. :) Ale zase dnes přišla chybová hláška od poskytovatele hostingu (ta přišla včera poprvé) :(

    V uctu 'lubos237' bezi prilis dlouho skript volany z IP adresy: 2a00:1ed0:1:1800:7:40:af00:1, Vhost: vysokorychlostni-zeleznice.cz, Request: POST /wp-cron.php?doing_wp_cron=1413248406.36649703979492187500.

    Jinak v dropboxu je normálně zabalený soubor se zálohou. Zkusil jsem ještě změnit Zip na Tar GZip. Tak uvidím zda to pomůže. taky jsem zaškrtnul Vámi doporučované “Don’t backup thumbnails from the site’s uploads folder.”

    #20701

    Lubos237
    Participant

    Hlásím možné řešení problému: v nastavení BackWPup jsem změnil formu komprese ze Zip na Tar GZip a dnes ráno žádná chybová hláška od poskytovatele hostingu o příliš dlouhém skriptu nepřišla.
    Akorát nevím jak se dá kompresi Tar GZip důvěřovat. Dá se rozbalit bez Linuxu?

    #20725

    Lubos237
    Participant

    Pro rozbalení souborů Tar GZip lze údajně využít program 7-zip.

    #31224

    skanzen
    Participant

    Dobrý deň.
    Dnes som nainštaloval tento plugin a rovnaké hlásenie (Maximum execution time of 30 seconds exceeded).

    Absolútne neakceptuje moje úpravy, čo sa týka nastavenia: Maximum script execution time… môžem dať 20, alebo aj 300 sekúnd, stále mi v informáciach deklaruje 30 sekúnd.

    Ďalej pakuje mi stále len do Tar súboru, nech zvolím aj Zip, a výsledný stiahnutý súbor má len 1kB.

    Zabudol som- vyššie uvedené som skúsil a nepomohlo zatiaľ nič.

    Kde mám hladať chybu? Ďakujem

    #31234

    Lubos237
    Participant

    Já mám nastaveno 40s a balím do Tar GZip. Jinak mi to nejde. Také mi stále chodí hláška ERROR: Maximum execution time of 40 seconds exceeded. Přesto se nakonec na dropboxu záloha objeví. Plugin BackWPup to vždy zkouší 2x, napodruhé se mu to vždy podaří. :-) Archive size is 178,58 MB.

    #31237

    skanzen
    Participant

    Ja som to vyskúšaní všetkých možností vzdal. Čokoľvek som zmenil, pludin nereagoval. Execution time bol stále 30 sekúnd koncovka zálohy stále .tar a archív v PC nešiel otvoriť vôbec.

    #31240

    Lubos237
    Participant

    Existuje nějaký jiný spolehlivý plugin pro vytvoření zálohy nejen databáze, ale i obrázků? A např. komentáře pod články nevím, zda se archivují v databázi nebo ne.

    #35127

    admin
    Keymaster
    Web

    Ještě se vrátím k pluginu BackWPup (nejnovější verze 3.4.5), a to na základě řešení problémů s @lubos237:

    – Databáze je zálohovaná komplet, tedy i včetně komentářů a dalších věcí.

    – Dále jsme tam měli problém WARNING: Link ".../wp-content/db.php" not following.. To bylo způsobeno pluginem Query Monitor, který si tam přidává symlink wp-content/db.php. Vyřešeno by to mělo být v nastavení BackWPup – Jobs – Edit – záložka Files – Exclude from backup – Exclude files/folders from backup – doplnit wp-content/db.php.

    – Dále tam byl starý známý problém ERROR: Maximum execution time of 40 seconds exceeded. Mělo by být vyřešeno v globálním nastavení pluginu, menu BackWPup – Settings – záložka Jobs – Maximum script execution time nastavit na hodnotu hodtingu (v tomto případě tedy 40). Při ručním spuštění zálohy hláška zmizela…

    – A jako poslední jsme tam měli duplicitní tvorbu zálohy, což bylo způsobeno aktivní Multisite. Plugin BackWPup patrně obsahuje chybu, že se záloha spouští pro každý web sítě samostatně (funkční je ale pouze jeden archiv se zálohou). Zkusil jsem to opravit a uvidíme, zda to bude fungovat. Snad se případná oprava dostane i do nové verze pluginu… Zajímavé, že duplicitní zálohy vznikají pouze při použití WP cronu, při ruční záloze je to v pořádku a vznikne jen jedna.

    Takže zatím na plugin BackWPup stále nedám dopustit, uvidíme :-)

Aktuálně je na stránce zobrazeno 12 příspěvků - 1. až 12. (z celkem 12)

Pokud chcete odpovědět na toto téma, musíte se nejdříve přihlásit.