Aktualizace PHP

Štítky: , , ,

Zvolené téma obsahuje celkem 5 odpovědí. Do diskuze (2 účastníci) se naposledy zapojil uživatel  admin a poslední změna je stará 9 let, 4 měsíce.

Aktuálně je na stránce zobrazeno 6 příspěvků - 1. až 6. (z celkem 6)
  • Autor
    Příspěvky
  • #22447

    Polo
    Participant

    Dobrý den, chtěl bych prosím požádat o radu ohledně aktualizace PHP.

    Momentálně mám WordPress 4.1.1, šablonu Graphene a PHP 5.2.17. Z hostingu OVH mi přišlo, že podpora starší verze PHP bude končit a je potřeba přejít na PHP 5.5 nebo 5.6, což ale nevím jak udělat – aktualizovat. Ani nevím zda na 5.5 nebo 5.6. U šablony by potíž být neměl, podporuje 4.0.4 a výše.

    Velice děkuji za pomoc

    #22461

    admin
    Keymaster
    Web

    Podle mě nemusíte dělat vůbec nic, WordPress funguje bez problémů i na novějších verzích PHP. Hosting pouze upozorňuje zákazníky, aby si to zkontrolovali a když třeba někdo používá vlastní aplikaci a nikoli WordPress, tak tam může mít nějaké problematické funkce.

    #22462

    Polo
    Participant

    Moc díky za odpověď. Jen doplňující otázka. Pokud hosting v tuto chvíli podporuje starší i novější verze PHP, co pak rozhoduje o tom, že já právě jedu na té staré verzi 5.2.17? Některé pluginy už mi totiž píšou hlášku, ať aktualizuju na vyšší PHP, že na starší nefungují..

    Díky

    #22477

    admin
    Keymaster
    Web

    Jaký používáte hosting? O používané verzi PHP rozhoduje hosting, možná máte třeba nějaké nastavení v administraci hostingu, kde můžete PHP verze přepínat. Takže pokud se objevují informace o zastaralé verzi PHP, tak to hosting patrně ještě nezměnil nebo si to musíte změnit někde sám (záleží na hostingu). Pokud žádné nastavení nenajdete, tak doporučuji kontaktovat přímo podporu hostingu…

    #22483

    Polo
    Participant

    Děkuji, možná by k tomu byla užitečná tato příručka, akorát bych prosím potřeboval polopaticky přeložit, co konkrétně mám udělat..
    http://prirucky.ovh.cz/Php5AtOvh
    Jak vkládat na FTP to vím..

    Velice děkuji

    #22484

    admin
    Keymaster
    Web

    Podle odkazovaného návodu musíte upravit soubor .htaccess (najdete ho na FTP) a doplnit tam následující řádek:

    SetEnv PHP_VER 5_4

    Potom byste měl fungovat na PHP 5.4. Ale nevím, jestli ten návod není zastaralý, protože tam nejsou vůbec zmíněné novější verze 5.5 a 5.6. Můžete to zkusit, případně kontaktovat podporu hodtingu.

Aktuálně je na stránce zobrazeno 6 příspěvků - 1. až 6. (z celkem 6)

Pokud chcete odpovědět na toto téma, musíte se nejdříve přihlásit.